@RequiresApi() and @ChecksSdkIntAtLeast() Annotations

@RequiresApi() and @ChecksSdkIntAtLeast() Annotations are used by lint tool in Android Studio to provide proper warning/error messages

Vincent Tsen
3 min readJun 24, 2023

--

One of the things I am confused about in Android development is these lint tool annotations. These annotations do not sound like lint tool annotations…

--

--